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1.0 Document
1.1 Revision History
Version
010

Date
10/14/2011

Comments
Initial Draft

1.2 Scope
The Camera Link module is an expansion board for the Tau camera that USB power and communication,
analog video, and digital data via Camera Link connection. The Camera Link module takes CMOS-type
digital data from the Tau camera and converts it to Camera Link. It is also possible to make hardware
modifications to this board to enable communication over Camera Link as well as access to external sync.
The FLIR website will have the newest version of this document as well as offer access to many other
supplemental resources: http://www.flir.com/cvs/cores/resources/
Here is a sample of some of the resources that can be found:
Document Title
Tau Quick Start Guide
FLIR Camera Controller GUI
User’s Guide
Tau 2 Product Specification
Tau 2 Electrical IDD

Document
Number
102-PS242-01
102-PS242-02
102-PS242-40
102-PS242-41

Tau 2/Quark Software IDD

102-PS242-42

Assorted Mechanical
Drawings and Models
Application Notes

Various

102-PS242-100-02 Rev100

Various

Description
Quick Start Guide for first-time use
Detailed Descriptions for functions and adjustments for
FLIR cameras using the FLIR Camera Controller GUI
Product specification and feature description
Written for Electrical Engineers to have all necessary
information to interface to a Tau 2 camera
Written for Software Engineers to have all necessary
information for serial control of Tau 2 and Quark
There are drawings and 3D models for various camera
configurations for mechanical integration
Written for Systems Engineers and general users of
advanced features such as Gain Calibration,
Supplemental FFC Calibration, NVFFC Calibration,
Camera Link, On-Screen Symbology, AGC/DDE
explanation, Camera Mounting, Spectral Response,
Optical Interface for lens design, and others.
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There is also a large amount of information in the Frequently Asked Questions (FAQ) section on the
FLIR website: http://www.flir.com/cvs/cores/knowledgebase/. Additionally, a FLIR Applications
Engineer can be contacted at 888.747.FLIR (888.747.3547).

2.0 Camera Link Operation
The Camera Link module is an expansion board for the Tau camera that matches the functionality of the
VPC Module and adds the ability to access digital data via Camera Link connection. The Camera Link
module takes CMOS-type digital data from the Tau camera and converts it to Camera Link. This module
does not include a Camera Link cable, frame grabber, or capture software.

2.1 Camera Link Module
The Tau Camera is powered through the mini-USB connector with a nominal draw of 180mA at 5VDC
for both the camera and the accessory. There is a peak startup draw of 500mA. The camera uses serial
communication at either 57600 or 921600 Baud by creating a virtual COM Port on your computer for
USB communications. The Baud Rate is selected using auto-Baud and the camera will communicate at
the first Baud Rate in which it receives a command until it is powered off.

Mounting Screws
M1.6 x 0.35 8 mm SHCS

Power Status Light

MCX coaxial
(analog video)
Mini Camera Link
(digital video)
Spacer
3 mm x 3.1 mm

Mini USB

Mounting Screws
M 1.6 x 0.35 x 16 mm
Figure 1: Tau Camera Link Module installed on a Tau 640 camera
The Camera Link Module takes CMOS-type digital data from the Tau camera and converts it to Camera
Link. In order to use a Camera Link Module for acquisition of data, you will need to first enable the
CMOS XP Bus Output using the FLIR Camera Controller. This option is found in the FLIR Camera
Controller GUI under Video => Digital Video. In the Camera Controller GUI, you can select either 8-bit
or 14-bit digital output.

2.2 FLIR Camera Controller GUI
The FLIR Camera Controller GUI provides communication between a PC and a Tau camera using either
the USB interface or some other means of serial communication.
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1. If you have an older version of the FLIR Camera Controller GUI loaded on your PC, you should
first uninstall it using the Windows Uninstall utility via the Windows Control Panel before
proceeding with this installation.
2. The newest version of the FLIR Camera Controller GUI can be found at the following URL:
http://www.flir.com/cvs/cores/resources/software/tau/
3. Click on the link to download the GUI and save it to your computer.
4. Extract the file using WinZip or other software. This can typically be done by right-clicking on
the zip file and selecting “Extract”.
5. Open the directory where you saved the file and double-click “setup.exe”.
6. Walk through the installation steps.
7. When the primary installation is completed, you will be prompted to install Silicon Laboratories
drivers. This portion of the installation is necessary for using a USB connection to the camera.
8. The program will install to Start→All Programs→FLIR Systems→Camera Controller GUI

2.3 Physical Connection
This section describes physical connections to the camera using the Camera Link Accessory Module.
1. Plug the accessory directly into the rear of the camera. There is a white 50-pin connector that will
mate. Use the included socket head cap screws to secure the expansion board to the camera.
These will insert on either side of the 50-pin connector. The Camera Link module uses M1.6 ×
0.35 × 8 mm screws. Using longer screws could damage the camera.
2. Connect the analog video cable to the Camera Link Module on the back of the Tau Camera.
There is an MCX mini coaxial connector on the back of the accessories. The opposite end of the
cable has a standard coaxial connector. Connect this to the video input of an analog monitor. It
may be necessary to use a BNC Female to Phono Plug (RCA) Adapter. These are readily
available at electronics stores and allow the camera to be connected to the standard yellow video
input on a monitor.

Figure 2: BNC to RCA Adapter
3. Connect the USB-mini B cable to the Camera Link Module and the USB-A end to your
computer. (If you have sound enabled on your computer, you should hear a chime and see a
notification that the device has been connected).
4. Analog video should appear within a few seconds after connecting the USB cable. Verify analog
video is displayed on the monitor to ensure the camera is properly powered.
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5. Additional Information: Access the Device Manager to verify proper driver installation and
identify communications port. Connection issues are most often caused by attempting to use
the wrong COM Port to connect to the camera.
a. Right-Click on “My Computer” and select “Manage”. This is typically either on the
desktop or available through the start menu.
b. Select “Device Manager” on the left Pane.
c. Expand the tree for “Ports (COM & LPT)”.
d. Note the COM Port number used for Silicon Labs. The following example shows COM3.

Figure 3: Device Manager showing proper driver installation

2.4 Software Connection
This section describes simple communication with the camera using the FLIR Camera Controller GUI
and assumes that the camera is connected to the PC using a USB cable and the Camera Link Accessory
Module. Please refer to the FLIR Camera Controller GUI User’s Guide for more details on functionality
of the FLIR Camera Controller GUI and the Tau camera.
1. Run the FLIR Camera Controller GUI by clicking on the start menu and accessing Start→All
Programs→FLIR Systems→Camera Controller GUI. (The software may take up to 30 seconds to
load the first time.
2. When the GUI first opens, it will display “Not Connected” on the bottom left. The first step is to
connect to the camera.

102-PS242-100-02 Rev100

October 2011

Page 6 of 16

Camera Link Module Accessory

Figure 4: FLIR Camera Controller GUI Status Tab – Not Connected
3. Connect to the camera by selecting Tools→ Connection

1

2
3

Figure 5: FLIR Camera Controller GUI Connection Window Part 1
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4. Select Serial (RS-232), select 921600 as the Baud Rate for fastest communication, and click
Next. If you only have one serial communication port on your computer, the button will say
Finish.

Figure 6: FLIR Camera Controller GUI Connection Window Part 2
5. Select the Com port seen in the Device Manager and click Finish.
6. The GUI will now automatically connect to the camera and refresh information in the software.
The status LED will turn green and it will display “Connected” on the bottom left. It is also
possible to retrieve the part number and serial number of your camera from this screen.

Figure 7: FLIR Camera Controller GUI Status Tab – Connected

2.5 Digital Data via Camera Link
This section describes digital data acquisition with the Camera Link accessory and assumes that all prior
sections have been successfully completed
1. Connect one end of the Camera Link cable to the camera. The camera connection is a MiniCamera Link connector and frame grabbers may use either standard or Mini-Camera Link. It is
possible to purchase cables that have mini connectors on both ends or standard on one end with
mini on the other.
2. The camera must be configured to output CMOS digital data in order for the Camera Link
accessory to work. This can be done by clicking “Video” on the left pane of the GUI, “Digital
102-PS242-100-02 Rev100
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Video” tab on the top, and selecting “CMOS” for the XP Bus Output. Select either 14-bit or 8-bit,
depending upon your preference. 8-bit data has the AGC applied and looks similar to the analog
video image. 14-bit data does not have AGC applied.

2
1

3

Figure 8: FLIR Camera Controller GUI – Digital Tab
3. Once you make these changes, it is a good idea to save settings to make them power cycle
persistent. This can be done on the Setup Tab by clicking the “Save Settings” button.
4. The digital data complies with Base Camera Link standards and will be compatible with most offthe-shelf Camera Link frame grabbers. FLIR has tested the ImperX FrameLink Express frame
grabber (http://imperx.com/frame-grabbers/framelink-express) and the Matrox Solios Camera
Link frame grabber
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(http://www.matrox.com/imaging/en/products/frame_grabbers/solios/solios_ecl_xcl_b/). It is
important to note that this module provides access to digital data only and the other portions of
the Base Camera Link specifications are not met. Camera control, external frame sync, and power
through the Camera Link connector are not supported. With simple hardware modifications, it is
possible to route communications through the Camera Link interface rather than through USB. It
is also possible to access the Tau camera’s external sync channel on the Camera Link accessory
through appropriate modification. Please consult a FLIR representative for details on these
modifications.
5. The FLIR Camera Controller GUI allows for control of the Tau camera, but does not support
Camera Link frame capture and so third-party software must be used. The ImperX frame grabber
includes FrameLink Express software that allows for recording single or multiple images (BMP,
JPG, TIF, and RAW) as well as standard AVI clips. Configuration requires selecting:
“1 TAP, L->R” for the tap reconstruction, selecting the same bit depth that you chose in the FLIR
Camera Controller GUI in step 2, and clicking “Learn” to discover the number of digital pixels
available.
6. Click Apply and Start Grab

2
1

3

4

Figure 9: Imperx FrameLink Express Software – Camera Parameters Window
7. Note: If the image appears to have very little contrast, the output is likely in 14-bit mode. If that is
the intended setting, use the histogram feature in the frame-grabber software to change the
display range. Otherwise, set the Tau camera to 8-bit Digital Output Mode and the frame-grabber
to 8-bit capture mode. Click “Apply” in the frame grabber software. The camera will now use its
built in AGC functionality that is accessible from the AGC tab in the FLIR Camera Controller
GUI.
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2.6 Troubleshooting the FLIR Camera Controller GUI
If the FLIR Camera Controller GUI does not link with the camera, you may see the popup shown below
which indicates that the GUI has not been able to communicate with the camera.

Figure 10: FLIR Camera Controller Error Message
If this is the case, verify the following:











The USB Cable is properly connected to both the computer and the Accessory Module so that
there is a green LED illuminated on the accessory.
Verify that you selected the proper port if it was not detected automatically. Select Advanced,
then Next in the Tools→Connection dialog box. Also, try disconnecting and then re-connecting
the cable to the PC. If the GUI was launched before the cable was connected, close the GUI,
connect the cable, and then re-launch the GUI.
The Baud rate must be set in the Tools→Connection dialog box. The Tau camera supports Baud
rates of 57600 and 921600. The Tau camera automatically detects if the Baud Rate of the first
incoming message is either 57600 or 921600 and will communicate at that Baud Rate until reset.
The Port may be occupied by another application. Shut down any other applications that may be
using the port. Also, multiple instances of the FLIR Camera Controller GUI Program can be
instantiated using different ports so be sure the camera you are interested in controlling is actually
connected to the physical port that was verified in the Device Manager in Section 3.2, step 5.
Verify that the camera is powered by checking that the camera is producing an image on an
analog monitor. On cameras with a shutter installed, listen for the sound of the FFC at startup.
There will be a clicking sound as the shutter is moved in and out of the field of view in the first 5
seconds after power is applied.
If the GUI says SWIR Camera Controller on the top, try to use Camera→Select to select FLIR
rather than SWIR. If this option is not present, you will need to uninstall the GUI using the
Windows Uninstall utility via the Windows Control Panel and delete the Program Files directory
(C:\Program Files (x86)\Flir Systems\Camera Controller GUI). You will also need to download
and install the latest .NET Framework from Microsoft (http://www.microsoft.com/net/download).
It is best to use the client profile from the web. Once this is updated, install the Camera Controller
GUI and use Camera→Select to select FLIR rather than SWIR.

If you cannot initiate serial communication with the camera after verifying these items, refer to the
frequently asked questions (FAQ) at http://www.flir.com/cvs/cores/knowledgebase/. Additionally, a FLIR
Applications Engineer can be contacted at 888.747.FLIR (888.747.3547).

3.0 Communications via Camera Link
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This section describes an optional hardware modification for serial communications through the Camera
Link connector and explains its use with an IMPERX FrameLink Express Frame Grabber. By default, the
CL board uses USB to communicate with the Tau and is effectively a VPC module plus Camera Link
digital data. With the removal of a single resistor, the board routes serial communications through the
Camera Link connector rather than the USB connector. Once this change is made, it is no longer
possible to communicate using USB. It is recommended that only technicians with solder experience
proceed with this modification and observe standard ESD practices.

3.1 Hardware Change
You will first need to remove the cover by removing two screws on the bottom of the board and two jack
screws on the Camera Link connector.

Figure 11: Philips screws to remove

Figure 12: Jack Screws to remove

As seen in the following Electrical Schematic, R11 is a 0 Ohm resistor that keeps SER_SELECT high.
When this is high, U11 (used for USB) is active and USB communications are used. When this resistor is
removed, SER_SELECT will be low. U11 will turn off and U10 (used for Camera Link Serial Coms) will
be enabled.

Figure 13: Electrical Schematic – Communication Circuitry
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October 2011

Page 12 of 16

Camera Link Module Accessory
Once you remove the cover, you will be able to remove the R11 resistor. It is on the top right corner with
a printed “0” on it.

Figure 14: Photo of R11

Figure 15: Board Layout of R11

After this resistor is removed, clean the area with Isopropyl Alcohol to remove flux. You can now put the
cover back on the board and replace both the jack screws on the Camera Link connector and the screws
on the bottom of the board.
The Camera Link Expansion Board will now Power the Tau camera over USB, communicate with RS422 serial communications over Camera Link, transmit digital data over Camera Link, and transmit
analog video using the MCX connection.

3.2 Communication with Camera Link frame grabber
Communication has been verified to work with the IMPERX FrameLink Express. This model is
ExpressCard/54 compliant and requires a 54 mm ExpressCard slot on a laptop or a PCI Adapter for use
with a desktop computer. An example for this is the “Best Connectivity ExpressCard to PCI-Express
Conversion Card SD-PEX-EXPC”. For more information on the IMPERX frame grabber consult the
manufacturer’s website: http://www.imperx.com/frame-grabbers/framelink-express.
Using the FrameLink Express software that is provided by IMPERX, it is possible to click View =>
Terminal. You must then check the HEX radio buttons for both receive and send and select a baud rate of
57600. Note that the IMPERX FrameLink Express is not capable of communicated at baud rates
exceeding 115200 and so the FLIR Tau option of 921600 is not available. This Terminal window will
allow you to manually enter HEX commands. Refer to the Tau Software IDD for a list of available
software commands. Test communications by sending the DoFFC command (6e 00 00 0c 00 00 aa da 00
00). This command will cause the image to freeze momentarily and you will hear the shutter click. Verify
the response from the camera.
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Figure 16: FrameLink Express – Terminal Window
It is also possible to create a Virtual COM port that can be used by the FLIR Camera Controller GUI.
This is the preferred method because you will have full access to all camera controls. With the Camera
Link card inserted and FLIR Camera Controller closed, run “FrameLink Express Virtual COM port”,
which installs in the Program Files directory along with the FrameLink Express Software. Select a COM
Port that is currently unused. This can be verified in the Device Manager under Ports. Click “Create Port”
and this virtual COM Port will remain accessible until it is deleted or this emulator is closed.

Figure 17: FrameLink Express – Virtual COM
You can now open the FLIR Camera Controller GUI to communicate with the camera as usual. Be
sure to select the correct COM Port and use 57600 baud.
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3.3 Communication with other Frame Grabbers
Although FLIR has only validated communications with the IMPERX FrameLink Express, it may be
possible to use other models. A potential frame grabber would need to be capable of differential serial
communications at 57600 or 921600 baud. Camera Link communications standards call for a differential
serial connection and so the FLIR Camera Link Expansion Board includes a differential serial line driver
to convert signals to RS-232 type signals for the Tau core. The following schematic shows connections on
the FLIR Camera Link board and the line driver.

Figure 18: Electrical Schematic – Camera Link Connector on Camera Link Accessory
It is important to note that a typical Camera Link interface cable flips the connector 180 degrees. This
means that pin 1 on the camera physically connects to pin 26 on the frame grabber, 2 to 25, etc. It is also
important to note that connections need to be exactly made and not inverted. For example, SerTC_P on
the camera needs to connect to SerTC_P on the frame grabber.

4.0 External Sync
The Camera Link accessory does not offer a connection for External Sync by default, but it is possible to
access this with modification. There is a header connection point on the Camera Link Accessory board
which provides access to the XP13 pin. This connects directly to pin 21 on the Tau 50 pin Hirose
connector which is the External Sync. The connection point is through-hole #3 on the PCB. This is a
through-hole that will require soldering. Hole #1 is the leftmost hole and is square in shape. This is a
direct connection to the FPGA so the input levels should be 0V to 3.3V. There is no over-voltage or
reverse voltage protection.
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The metal case will also require modification to allow the wire to pass out. A small hole can be drilled in
the metal case to match the approximate location shown in the image of the camera assembly.

Figure 19: Ext Sync Header Connection
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