IOI HD

Release Notes

FW v. dt20160907NSX
# Table of Contents

1. Version Content .............................................................................................................. 1
   1.1 Version Details ............................................................................................................ 1
   1.2 Firmware Version Location .......................................................................................... 1

2. Supported Products and Platforms .............................................................................. 3

3. Key Features .................................................................................................................. 5
   3.1 Rebranding and New UI Look and Feel ................................................................. 5
   3.2 New Sensor in all IOI HD Cameras ............................................................................. 5
   3.3 New Resolution in CF-5212 ..................................................................................... 5
   3.4 Support for Third-Party VMS Systems ...................................................................... 5

4. Limitations ....................................................................................................................... 7

5. Known Issues .................................................................................................................... 9

6. Upgrade Procedure ....................................................................................................... 11
   6.1 Upgrading the Camera through DNA ....................................................................... 11
   6.2 Upgrading the Camera through the Web Interface .................................................. 12

7. United VMS Compatibility ............................................................................................ 15
   7.1 Upgrade Procedure ................................................................................................. 15
   7.2 Upgrade Procedure ................................................................................................. 15
   7.2.1 Latitude 6.4 Update Patch ................................................................................... 15
   7.2.2 Latitude 7.0 Update Patch ................................................................................... 15
   7.3 ioi Limitations in Latitude ......................................................................................... 16

8. Disclaimer ......................................................................................................................... 17
1. **Version Content**

This release supports the key features listed in section 3. In addition to documenting the Key Features, these release notes cover Supported Products and Platforms, Limitations, Known Issues, Upgrade Procedure, and United VMS Compatibility.

1.1 **Version Details**

Full version details:

- Camera firmware version dt20160907NSX
- Analytics firmware version 2.1.3.72

1.2 **Firmware Version Location**

This firmware version is available from [here](#).
## 2. Supported Products and Platforms

This version is applicable to the following products:

<table>
<thead>
<tr>
<th>Product Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>CB-5222-11</strong></td>
<td>Full HD 1080p bullet IP camera with built-in video analytics. D/N, WDR, IR Cut Filter, H.264, 25/30 fps. 1/2.8&quot; 2.1MP CMOS, F1.4 motorized 3-10.5mm auto-focus, DC-Iris lens. 12VDC/24VAC/POE/POE+.</td>
</tr>
<tr>
<td><strong>CB-5222-21</strong></td>
<td>Full HD 1080p bullet IP camera with built-in video analytics. D/N, WDR, IR Cut Filter, H.264, 25/30 fps. 1/2.8&quot; 2.1MP CMOS, F1.4 motorized 7-22mm auto-focus, DC-Iris lens. 12VDC/24VAC/POE/POE+.</td>
</tr>
<tr>
<td><strong>CB-5222-31</strong></td>
<td>Full HD 1080p bullet IP camera with built-in video analytics. D/N, WDR, IR Cut Filter, H.264, 25/30 fps. 1/2.8&quot; 2.1MP CMOS, F1.6 motorized 6-50mm auto-focus, DC-Iris lens. 12VDC/24VAC/POE/POE+.</td>
</tr>
<tr>
<td><strong>CF-5212</strong></td>
<td>IOI HD 720p fixed IP camera with built-in video analytics and H.264/MJPEG compression. D/N, WDR, IR Cut Filter, H.264, 25/30 fps. 1/3&quot; 1.3MP CMOS, with a choice of Auto-Iris, IR corrected lenses. 12VDC/24VAC/POE (802.3af Class 0).</td>
</tr>
<tr>
<td><strong>CF-5222</strong></td>
<td>IOI HD 1080p fixed IP camera with built-in video analytics and H.264/MJPEG compression. D/N, WDR, IR Cut Filter, H.264, 25/30 fps. 1.3MP CMOS, with a choice of Auto-Iris, IR corrected lenses. 12VDC/24VAC/POE (802.3af Class 0).</td>
</tr>
<tr>
<td><strong>United 6.4 Update 6.4.0.6830 and higher</strong></td>
<td>Update that supports these cameras is mandatory. Select Latitude, Horizon, or Meridian Update file.</td>
</tr>
<tr>
<td><strong>United 7.0 Update 7.0.0.5710 and higher</strong></td>
<td>Update that supports these cameras is mandatory. Select Latitude, Horizon, or Meridian Update file.</td>
</tr>
<tr>
<td><strong>DNA 2.1</strong></td>
<td>Discovery Network Assistant (DNA) version 2.1.0.17 and above support IOI unit discovery, setup and firmware upgrade.</td>
</tr>
</tbody>
</table>
3. **Key Features**

3.1 **Rebranding and New UI Look and Feel**

IOI HD cameras have been rebranded as FLIR models and feature a new user interface.

3.2 **New Sensor in all IOI HD Cameras**

This firmware version supports both the original Sony sensor and the new Sony sensor for the IOI HD cameras. The component change was required due to loss of production at the Sony Fab due to an earthquake. The new sensor is better in all respects.

3.3 **New Resolution in CF-5212**

The CF-5212 now supports 1600 x 896 resolution.

3.4 **Support for Third-Party VMS Systems**

Support for certain third-party VMS systems is now possible by selecting the *Enable Alternative ONVIF IO Events* checkbox in the *ONVIF section of the Events Setup > IO screen.*

The current release supports the following third-party VMS systems:

- Milestone XProtect Corporate
- Milestone XProtect Enterprise
- SureView IMMIX CS
4. Limitations

The following table refers to limitations in the current release and in the GA release:

<table>
<thead>
<tr>
<th>BUG ID</th>
<th>SUMMARY</th>
<th>COMMENTS</th>
</tr>
</thead>
<tbody>
<tr>
<td>771</td>
<td>CB-5222 and CF-5212/5222 – Invalid NTP addresses are not indicated to the user.</td>
<td>Limitation by design</td>
</tr>
<tr>
<td>786</td>
<td>CB-5222 and CF-5212/5222 – The camera configuration restore process does not include a progress bar.</td>
<td>Limitation by design</td>
</tr>
<tr>
<td>31510</td>
<td>CB-5222 and CF-5212/5222 – The analytic firmware downgrade operation is not supported.</td>
<td></td>
</tr>
<tr>
<td>32192</td>
<td>CB-5222 and CF-5212/5222 – The analytic service takes an additional minute to initialize and provide detection after the camera is accessible.</td>
<td></td>
</tr>
<tr>
<td>38379</td>
<td>A snapshot or recording is not created unless the user runs IE as Administrator in Windows 8.</td>
<td>Define a storage location that does not require Administrator privileges on the PC.</td>
</tr>
<tr>
<td>38387</td>
<td>The user must be defined and set as an administrator to install DVPlayer on Windows 8 and 8.1.</td>
<td>Log in as Administrator or right-click Internet Explorer and run as Administrator</td>
</tr>
<tr>
<td>38388</td>
<td>Audio Out does not work when the camera is set to Multicast mode.</td>
<td></td>
</tr>
<tr>
<td>40573</td>
<td>CB-5222 and CF-5212/5222 – The camera sets the Set camera height parameter, but does not save the setting upon refresh.</td>
<td></td>
</tr>
</tbody>
</table>
5. **Known Issues**

The following table refers to known issues in the current release and in the GA release:

<table>
<thead>
<tr>
<th>BUG ID</th>
<th>SUMMARY</th>
<th>COMMENTS</th>
</tr>
</thead>
<tbody>
<tr>
<td>38403</td>
<td>Boost upon alarm is not supported on United VMS.</td>
<td></td>
</tr>
<tr>
<td>40452</td>
<td>A Response event occurs twice after reset.</td>
<td></td>
</tr>
<tr>
<td>41567</td>
<td><strong>Analytics &gt; Rules</strong> screen – When running IE 10, after clicking <strong>APPLY</strong>, the “Saving configuration” message is displayed in the background behind the Live View.</td>
<td>Scroll down in order to view the message.</td>
</tr>
<tr>
<td>41608</td>
<td>Occasionally, when installing ActiveX for the first time, a message is displayed that ActiveX could not be installed.</td>
<td>In the Internet Explorer <strong>Tools &gt; Internet Options &gt; Advanced</strong> Security settings section, select the “Allow software to run or install even if the signature is invalid” checkbox. Uncheck the checkbox after installing ActiveX.</td>
</tr>
</tbody>
</table>
6. Upgrade Procedure

If it is necessary to upgrade the camera system firmware and analytics firmware. Each firmware is contained in a separate file.

The firmware can be updated by using the Discovery Network Assistant (DNA) tool or the camera’s web interface.

**Note:**
It is recommended to update via DNA if you are upgrading multiple units.

### 6.1 Upgrading the Camera through DNA

FLIR’s DNA tool can be used to upgrade the camera’s system firmware and the analytics firmware simultaneously. After upgrading the camera and analytics firmware, you must upgrade the web page firmware. You can download the latest DNA software version from [here](#).

**Note:**
Only DNA version 2.1.0.17 or higher supports CB-5222.

To upgrade the camera and analytics firmware

1. Backup your system configuration before performing the upgrade procedure. Backup the analytics configuration by opening the **Analytics > Backup & Restore** screen.

2. Upon discovery of the ioi HD unit(s), select the relevant unit(s) from the Discovery list.
   a. Select the unit(s) to upgrade.

   ![Figure 1: DNA Discovery List](#)

   b. Click the **Firmware** icon on the navigation bar.

   c. Select the camera firmware file (uImage_userland_ioi_HD_camera_20160907.img) and analytics firmware file (ioi_HD_analytic_2_1_3_72_PAL.utk for PAL or ioi_HD_analytic_2_1_3_72_NTSC.utk for NTSC) from the relevant fields in DNA.
Upgrade Procedure

Figure 2: Select Upgrade Firmware Files

d. Click the **Upgrade** button. DNA upgrades both files simultaneously.

e. Restore the analytics setting by selecting **Analytics settings from file** in the **Restore** section of the **Analytics > Backup & Restore** screen.

![Warning](image)

**Caution:**
Performing an analytics restore deletes all settings except the Depth and Rules settings. Responses, Scheduled Actions and On-Screen Display screen settings will not be saved. It is NOT recommended to select **Full restore from file**, which disables the Enhanced detection function.

For further details, refer to the *DNA 2.1 User Manual*.

### 6.2 Upgrading the Camera through the Web Interface

It is necessary to upgrade the camera system firmware and analytics firmware, each of which are contained in separate files. The firmware should be updated in this order:

1. Update analytics firmware
2. Update camera firmware

**To upgrade the analytics firmware**

1. Select the **SETTINGS** tab on the navigation bar.
   a. Select the **Analytics > Firmware** tab on the sidebar.
   b. Click the **Browse** icon to locate the analytics firmware file.
      - For PAL, select `ioi_HD_analytic_2_1_3_72_PAL.utk`.
      - For NTSC, select `ioi_HD_analytic_2_1_3_72_NTSC.utk`.
   c. Click the **UPGRADE** button to upload the analytics firmware. The firmware upgrade process starts.
   d. Restore analytic settings from the backup file.
To upgrade the camera firmware

1. Backup your system configuration before performing the upgrade procedure. Backup the analytics configuration by opening the Analytics > Backup & Restore screen.

2. Select the SETTINGS tab on the navigation bar.
   a. Select the System > Maintenance > Software Upgrade tab on the sidebar.
   b. From Step 1 on the screen, select the binary file to upload (uImage_userland_ioi_HD_camera_20160907.img).
   c. From Step 2 on the screen, select the file uImage_userland.
   d. Click Upgrade. The firmware upgrade process starts.
7. United VMS Compatibility

It is necessary to install an Update Patch in order for ioi HD to operate with United VMS 6.4 and United VMS 7.0. Select the Update Patch file according to the platform (Latitude, Horizon, or Meridian).

7.1 Upgrade Procedure

If you do not have United VMS 6.4 or United VMS 7.0:

- If you have Latitude 6.2, first upgrade to Latitude 6.3.
- If you have Latitude 6.3, upgrade to United VMS 6.4.
  1. Install United VMS 6.4 on all client and server machines.
  2. Install the Update Patch 6.4.0.6830 or higher version on all servers.
- If you have United VMS 6.4, you can upgrade directly to United VMS 7.0.

7.2 Upgrade Procedure

If you do not have Latitude VMS 6.4 or Latitude VMS 7.0:

- If you have Latitude 6.2, first upgrade to Latitude 6.3.
- If you have Latitude 6.3, upgrade to Latitude VMS 6.4.
  1. Install Latitude VMS 6.4 on all client and server machines.
  2. Install the Update Patch 6.4.0.6830 or higher version on all servers.
- If you have Latitude VMS 6.4, you can upgrade directly to Latitude VMS 7.0.

7.2.1 Latitude 6.4 Update Patch

To install the Latitude 6.4 Update Patch

1. Download the Update Patch from here.
2. Run the file on every server and workstation in the system.
3. Upgrade the Directory/EDB.
4. Upgrade each Archiver.
5. After all the servers are upgraded, upgrade the workstations using the method below.
6. In the Latitude client application, from the Help tab, select the Check for Updates option. A popup opens, indicating that there is an update to download from the Update server.
7. Select Yes to download the update file. A popup appears on the screen.
8. Click Install. The installation may take several minutes.

7.2.2 Latitude 7.0 Update Patch

To install the Latitude 7.0 Update Patch

1. Download the Update Patch from here.
2. Run the file on every server and workstation in the system.
3. Upgrade the Directory/EDB.
4. Upgrade each Archiver.
5. After all the servers are upgraded, upgrade the workstations using the method below.
6. In the Latitude client application, from the Help tab, select the Check for Updates option. A popup opens, indicating that there is an update to download from the Update server.
7. Select **Yes** to download the update file. A popup appears on the screen.
8. Click **Install**. The installation may take several minutes.

### 7.3 ioi Limitations in Latitude

Limitations exist on using Latitude to change the following settings, which can be changed on the ioi HD Streaming screen:

- **Streaming > Video Format > Video Resolution**: To set MJPEG on Latitude, from the Video Settings > Live> Advanced Settings > Compression screen, right-click the unit on the camera tree, and from the Rediscover unit dialog box, select the Discover MJPEG video encoders checkbox. To set H.264, do not select the checkbox. Click **OK**. The unit is rediscovered with the new video resolution.

![Rediscover unit dialog box](image)

- **Streaming > Video Format > GOV Settings**: To change the GOV setting from Latitude, you must multiply the frame rate by the key frame interval in order to obtain the desired GOV setting. Go to Video Settings > Live. In the **General area**, enter the frame rate in the Frame Rate field. In the **Advanced area**, enter the key frame interval in the Key Frame Interval field.

- **Streaming > Video Compression > MJPEG/H.264 Compression setting**: You must rediscover the unit after changing the setting in Latitude in Video Settings > Live> Advanced Settings> Rate Control Mode.

- **Streaming > Video OCX Protocol**: If you select Unicast or Multicast mode for the video on Latitude on the General > Stream Connection Type screen, this setting is also applied to the audio in port on the device’s Microphone screen.

- **Streaming > Video Compression > CBR mode setting**: Constant Bit Rate is detected automatically by Latitude in Video Settings > Live> Advanced Settings> Rate Control Mode. This setting cannot be changed in Latitude.

- **Camera > Wide Dynamic Range**: This setting cannot be changed in Latitude.

- **Camera > Backlight Compensation**: This setting cannot be changed in Latitude.

- **Camera > Day/Night**: This setting cannot be changed in Latitude.
8. Disclaimer

By providing this document, FLIR Systems, Inc. is not making any representations regarding the correctness or completeness of its contents and reserves the right to alter this document at any time without notice.

© FLIR Systems, Inc. 2016. All rights reserved.